Topic: Report error

Hello friends... how are you....
i am generating summary using script... script works and shows data in tablegrid but does not shows data in report....

select
       a.id,
       a.Pump_Name,
       sum(b.Delivery_Volume),   
       sum(b.Delivery_Value)
       
from   tblPump a,         
       tblHoseDelivery b
     
                   
where  a.id = b.id_tblPump
  and  b.Completed_TS >= {datetimepicker3}
  and  b.Completed_TS <= {datetimepicker4}
group by a.id
;

in report im using master data1...

Post's attachments

Attachment icon untitled2.zip 70.1 kb, 44 downloads since 2019-01-07 

Re: Report error

не понятно, можно проект?  почему sum?

Re: Report error

i attached sample project... data is stored from 4 jan 2019 to 6 jan 2019....
report to grid shows data in tablegrid...
report to print not works.....

Post's attachments

Attachment icon test.zip 752.9 kb, 46 downloads since 2019-01-07 

Re: Report error

https://downloader.disk.yandex.ru/preview/f85703e02cbb6dd7b558963ed4df77c3f395fa2e74a6a05fedfd0b84830c5320/5c33fe40/wen71ENjM59wrRqPBbBXurIPhcrcWIeZu8fdEfXQaWgT21goefgyZq8RtCer7rmt7gJK163KfQaZMjazq5TlAQ%3D%3D?uid=0&amp;filename=111lllll.jpg&amp;disposition=inline&amp;hash=&amp;limit=0&amp;content_type=image%2Fjpeg&amp;tknv=v2&amp;size=2048x2048
 
 
https://downloader.disk.yandex.ru/preview/e63b19e2b7876c82e3ef0c70b738b8926df40fb8177e2f40a68e19839174b62e/5c33fe48/wen71ENjM59wrRqPBbBXuk1RnCBAtHIiHW8Z38N0rXRtarQuV7O6TxBZCnhxPXDPkMSKncaNpCP4mFhpKYoRqQ%3D%3D?uid=0&amp;filename=222iii.jpg&amp;disposition=inline&amp;hash=&amp;limit=0&amp;content_type=image%2Fjpeg&amp;tknv=v2&amp;size=2048x2048
 
 
https://downloader.disk.yandex.ru/preview/55c9121078a9410490df893473a673eda9754d4ff7f848fce352c0c939387537/5c33fe4f/wen71ENjM59wrRqPBbBXujn3O05x8FMkeSPsPtw5l6__tkNMpYwcZojai_zsOpt5GV2iyQP2jCCgzTah9_7Gvw%3D%3D?uid=0&amp;filename=333iii.jpg&amp;disposition=inline&amp;hash=&amp;limit=0&amp;content_type=image%2Fjpeg&amp;tknv=v2&amp;size=2048x2048

Re: Report error

links not works.. links cant open

Re: Report error

blackpearl8534 wrote:

links not works.. links cant open

Post's attachments

Attachment icon wwwe.7z 252.83 kb, 44 downloads since 2019-01-08 

Re: Report error

i  also configured like this.. and its works properly on grid but not on report...

Re: Report error

Hi Raheel, Sibprogsistem,
Can you try the attached and see if it's working correctly?
Thanks,
Derek.

Post's attachments

Attachment icon test derek.zip 753.01 kb, 61 downloads since 2019-01-09 

Re: Report error

derek wrote:

Hi Raheel, Sibprogsistem,
Can you try the attached and see if it's working correctly?
Thanks,
Derek.

YES

10 (edited by blackpearl8534 2019-01-09 11:07:48)

Re: Report error

thanks DEREK...
but there is a problem..
when we use {fromdatepicker} and {todatepicker} then system loads date like this
"2019-01-09 00:00:000"....
so need date and time both selection.... so need help ....

Post's attachments

Attachment icon derek.JPG 27.71 kb, 34 downloads since 2019-01-09 

11 (edited by derek 2019-01-10 13:41:18)

Re: Report error

Hi Raheel, Sibprogsistem,
I've used a small bit of script to concatenate 'fromdate' and 'fromtime' into 'edit1' and concatenate 'todate' and 'totime' into 'edit2' (all hidden) and reformat 'edit1' and 'edit2' to yyyy-mm-dd hh:mm:ss. 
Then I use 'edit1' and 'edit2' in my 'Report SQL' and this seems to work - the tablegrid and the report are identical.
I think this should solve your problem.
Regards,
Derek.

Post's attachments

Attachment icon test derek2.zip 754.46 kb, 62 downloads since 2019-01-10