Topic: Not all fields in the report

Hi everyone,
I made this project, in the second form (frmIns Insertion) I put a button (Print) to print a report that is a receipt. The problem is that despite having put all the fields in the report, only some of these fields appear to me.
Can anyone take a look at the project I'm attaching?
Thank you so much.

Post's attachments

Attachment icon Ricevute.zip 327.42 kb, 9 downloads since 2019-04-12 

Re: Not all fields in the report

Hi I am new to MVD as well.

But per checking on your "print button" it seems your "fast report" settings is not yet setup.

Please click the print button then set your "fast report settings" by dragging the data on the left right side

to the middle of the paper.


Here is the exact guide.

http://myvisualdatabase.com/forum/viewtopic.php?id=4

Re: Not all fields in the report

Hello Reteinformatica,
As far as I can see, all of the fields appear on the report except 'Provincia' (this is because you have defined it in the 'anagrafica' table but you are not entering it on any of the forms, so it is always blank).
I have entered test data into all of the other fields that you are passing through to the report (as selected on your print button (b5 stampa) and they are displaying correctly on the report.
Derek.

Post's attachments

Attachment icon Ricevute.zip 342.9 kb, 12 downloads since 2019-04-12 

Re: Not all fields in the report

What a stud! I hadn't filled the fields and for this reason I didn't see anything.
I made some adjustments to the program and now I have a problem that I can't solve: by clicking on the first form (frmStart) and searching for a user, having done the search by double-clicking on the user, I rightly open the frmInsertion form, but to close this form whether you click on the X or the "Chiudi" button, the form closes only after clicking a second time on the X or on the Close button.
Thanks a lot!

Post's attachments

Attachment icon Ricevute3 - Copia.zip 364.47 kb, 9 downloads since 2019-04-15 

5 (edited by derek 2019-04-15 16:54:01)

Re: Not all fields in the report

Ciao Reteinformatica,
The reason why you have to click two times is because you have defined two different buttons to 'show record' (see attached screen shot).
Change the 'stampa' button from 'show record' to 'report' and this should fix the problem.
Regards,
Derek.

Post's attachments

Attachment icon ricevute3 - copia.jpg 258.68 kb, file has never been downloaded. 

Re: Not all fields in the report

Thanks very much Derek.
I would always have another request on this project: if you look at the commented part in the scripts and you uncommented it, you will see that "frmInfo" is hidden by clicking on it, as instructed, but you will see that then the program completely crashes.

Re: Not all fields in the report

Hi,
'Hiding' frminfo is not the same as 'closing' it;  even though it is hidden, it is still active and therefore affects how your program behaves.
I would suggest you use frminfo.close instead.
procedure frmInfo_OnClick (Sender: TObject);
begin
  frmInfo.close;
end;
Derek

Re: Not all fields in the report

Thanks Derek, you solved all my issues.