Topic: Printing with Richedit has a lot of codes (gibberish)

Hi guys can you please help me with this one.

If I use a normal "memo" it is working fine but I replaced it with Richedit the form just go out out whack.

There are codes, etc. Can you please help me how to set it so that the gibberish codes will disappear

and only the list of data in the participants etc. will appear.

Any help is appreciated.

Thank you.

Post's attachments

Attachment icon printing issue.rar 337.02 kb, 36 downloads since 2019-06-21 

Re: Printing with Richedit has a lot of codes (gibberish)

Hello.


In the report, you should use RichText Object instead Text Object if you store data in a database using RichEdit component.


p.s.
Please don't use pirate version of software.

Dmitry.

Re: Printing with Richedit has a lot of codes (gibberish)

Hi Drivesoft.

I have encountered a similar issue like this before but wasn't able to solve it.
How do you use a richtext object  to a richtext edit? Can you please point to me where the setting is located?

Re: Printing with Richedit has a lot of codes (gibberish)

In the report designer:
RichText object has properties, just specify them:
Dataset: Report
DataField: fieldname

Dmitry.

Re: Printing with Richedit has a lot of codes (gibberish)

hmmmmm, i think it is still not working on my end.

I tried the example above  as well and it is showing like this one. How do I remove the /tabs, the /pars and the one with the {     }.
Cause if I try a memo instead of a rich text it is working perfectly.

Post's attachments

Attachment icon Untitled.png 31.46 kb, 26 downloads since 2019-06-22 

6 (edited by derek 2019-06-22 10:22:04)

Re: Printing with Richedit has a lot of codes (gibberish)

Hi,
It sounds like you are either dragging the datafield directly into the report or selecting the RTF component and then dragging the datafield into the RTF component - in both instances, this will result in you seeing /tab /par {{!! etc etc.
You must first place an RTF component into the report.
Then you must specify the dataset and the datafield USING THE RTF object's properties (don't drag and drop it from the list of available datafields.
Please have a look at the screenshot (screenshot1.jpg) in the attached example.
Hope this helps,
Derek

Post's attachments

Attachment icon printrtf.zip 654.97 kb, 52 downloads since 2019-06-22 

Re: Printing with Richedit has a lot of codes (gibberish)

Thanks again for the detailed explanation.

I learned a lot.