1 (edited by thezimguy 2020-01-18 17:26:25)

Topic: [SOLVED] TableGrid Events not working

Hello Dmitry, Derek and MVD lovers,
I don't seem to get the following TableGrid Events to work for me

OnBeforeEdit
OnBeforeEdit
OnEditAccept
OnApplyEditText

I made the tableGrid editable and was trying to use the following code to detect if the edit was accepted but gets errors.

procedure frmRegister_tGrid_OnEditAccept(Sender: TObject; var Cancel: boolean);
begin
    ShowMessage('Its working');
end;

Any help?
Thank you in advance.

@thezimguy

Re: [SOLVED] TableGrid Events not working

I CHECKED THIS WORK

Re: [SOLVED] TableGrid Events not working

Hi Zimguy, Hi Sibprogsistem,
Yes, also okay for me.
One thing you might check is whether the 'secondclickedit' property of the 'editable grid' is checked.  I don't believe it should make a difference but sometimes you can 'miss' the second click and so it appears that it's not working.
Please see the attached.
Derek.

Post's attachments

Attachment icon tableeditproblem.zip 472.38 kb, 25 downloads since 2020-01-11 

Re: [SOLVED] TableGrid Events not working

Thank you so much Derek and sibprogsistem
I forgot to add the ACol, ARow, Accept and Value to the procedure.
It's working
I really appreciate your help

@thezimguy

Re: [SOLVED] TableGrid Events not working

Hi family, please how do I remove horizontal scrollbars from empty grid.
I have realized that the settings.ini has some number of rows and widths for the grid and this make the grid show horizontal scrollbars.
Any help?

@thezimguy

Re: [SOLVED] TableGrid Events not working

Hi,
Perhaps you could do something like the attached (not really tested it but the theory looks good - LOL!).
Please note you need to be using MVD v6 or above.
Derek.

Post's attachments

Attachment icon horizontalscrollbar.zip 337.34 kb, 29 downloads since 2020-01-14 

Re: [SOLVED] TableGrid Events not working

derek wrote:

Hi,
Perhaps you could do something like the attached (not really tested it but the theory looks good - LOL!).
Please note you need to be using MVD v6 or above.
Derek.

Thank you Derek. This did the trick
You are a genius.

@thezimguy

Re: [SOLVED] TableGrid Events not working

It was a bug. Please download latest beta version, fixed
https://www.dropbox.com/s/gczabpgu8tyei … a.zip?dl=0

Dmitry.

Re: [SOLVED] TableGrid Events not working

The problem is still persistent even though I have download the 6.3beta from the link above.
I'm using button search to load the data into the tableGrid.
Thank you.

@thezimguy

Re: [SOLVED] TableGrid Events not working

thezimguy wrote:

The problem is still persistent even though I have download the 6.3beta from the link above.
I'm using button search to load the data into the tableGrid.
Thank you.

please attach your project, I will test it.

Dmitry.

11 (edited by thezimguy 2020-01-16 04:31:50)

Re: [SOLVED] TableGrid Events not working

Please, find attached

Post's attachments

Attachment icon tableGrid.zip 3.43 kb, 9 downloads since 2020-01-16 

@thezimguy

Re: [SOLVED] TableGrid Events not working

Hello thezimguy

Why your Edit1 fields TableName and FieldName are both empty ?

JB

Re: [SOLVED] TableGrid Events not working

thezimguy wrote:

Please, find attached

Fixed
https://www.dropbox.com/s/gczabpgu8tyei … a.zip?dl=0

Dmitry.

Re: [SOLVED] TableGrid Events not working

Thank you very much boss
I worked perfectly

@thezimguy

Re: [SOLVED] TableGrid Events not working

Testing 6.3 beta i have a problem with Tablegrid_OnCellClick  ... it worked fin in 6.2 but doesn't work in 6.3 beta.

could you please check it ???

BR

Maik

16

Re: [SOLVED] TableGrid Events not working

lupo1st,
It works fine for me in 6.3 Beta. Attach your project so people here can give assistance.

Re: [SOLVED] TableGrid Events not working

Checked, it works.

Dmitry.